LANCOM-Forum.de

Das inoffizielle Profi-Forum für LANCOM-User
Aktuelle Zeit: 18 Jan 2018, 06:13

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]




Ein neues Thema erstellen Auf das Thema antworten  [ 1 Beitrag ] 
Autor Nachricht
 Betreff des Beitrags: OSPF und VPN
BeitragVerfasst: 27 Sep 2017, 00:11 
Offline

Registriert: 14 Mär 2012, 13:36
Beiträge: 346
Hallo miteinander,

ich beschäftige mich gerade etwas mit OSPF und muss zugeben, dass ich vorher keine großartigen Berührungspunkte damit hatte.

Es handelt sich hierbei um ein Testszenario, was ich mit zwei unterschiedlichen Routern nachgestellt habe. Einmal ein vRouter, der mit komplett neuer Config hochgezogen wurde und zur Kontrolle mein privater 1781EF+. Beim 1781EF+ war kein weiterer Router da, um die Route aufzunehmen, aber bei beiden sind die Fehlermeldungen identisch, daher sehe ich hier nicht den Fehler.

Es geht darum, dass ich verbundene VPN-Endstellen per OSPF bekannt machen möchte, so wie ich es bisher mit RIP mache. Also eine VPN-Verbindung angelegt (bzw. eine vorhandene funktionierende genutzt), in der Routingtabelle die Routen konditional für RIP gemacht und dann OSPF konfiguriert.

Also OSPF an, die DEFAULT-OSPF-Instanz mit einer Router-ID angelegt (vRouter 172.21.31.1, EF+ 10.27.1.1, sind die IPs des INTRANET), die Instanz der OSPF-Area 0.0.0.0 zugeordnet, das INTRANET-Interface ebenfalls der Default-Instanz und der Area 0.0.0.0 zugeordnet und die Redistribution der statischen Routen aktiviert. Alles zurückgeschrieben und schön.

Ich habe dann ein komplettes OSPF-Trace laufen lassen und die VPN-Verbindung aufgebaut. Die Route wird nicht per OSPF verbreitet und im Log finde ich dann solche Einträge:
Code:
[OSPF-Redistribution] 2017/09/26 23:53:56,922 : reject static route to 10.27.2.2/32 (null route)

(10.27.2.2 ist die IP-Adresse auf der anderen Seite des VPN-Tunnels, mit einem /24-Netz bekomme ich aber den gleichen Fehler)
Als weiteren Versuch habe ich dann mal die Redistribution der statischen Routen abgeschaltet und die VPN-Verbindung als passive OSPF-Schnittstelle angelegt, was auch nicht klappt.
Code:
[OSPF-Redistribution] 2017/09/26 23:54:46,969 : reject static route to 10.27.2.2/32 (no redistribution of protocol)


Andere Schnittstellen oder andere statische Routen (z.B. WAN-Interfaces) werden per OSPF verteilt.

Jetzt stelle ich mir die Frage, was ich was falsch mache und wie ich den Router dazu bekomme, die IPSec-VPNs zu verteilen. Wie gesagt, ist mein erster größerer Kontakt mit OSPF.

Schönen Abend und beste Grüße

5624

_________________
LCS NC/WLAN


Nach oben
 Profil  
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 1 Beitrag ] 

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 7 Gäste


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.
Du darfst keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
cron
Powered by phpBB® Forum Software © phpBB Group