ADSL-Modem defekt und DSL-LED blinkt weiter orange statt rot

LCOS/LCMS Release Update Betatest: Um den Benutzern des LANCOM-Forum.de schon vor der finalen Freigabe eines Release Update die Möglichkeit zu geben gemeldete Fehler und Verbesserungen zu testen, wird dieser Bereich ins Leben gerufen. Hier werden nun in regelmäßigen Abständen neue LCOS und LCMS Versionen als Betatest-Varianten abgelegt.

Wichtig, bitte beachten: Rückmeldungen zu den Versionen sind im Forum sehr willkommen, aber bitte auch nur ausschliesslich im Forum. Bitte keine Fragen zu den hier angebotenen Vorabversionen direkt an den LANCOM Support stellen!

Moderator: Lancom-Systems Moderatoren

Antworten
Benutzeravatar
Jirka
Beiträge: 4081
Registriert: 03 Jan 2005, 14:39
Wohnort: Ex-OPAL-Gebiet
Kontaktdaten:

ADSL-Modem defekt und DSL-LED blinkt weiter orange statt rot

Beitrag von Jirka » 12 Jan 2018, 17:34

Hallo,

1781AW, Firmware 9.24.0350

das ADSL-Modem im LANCOM 1781AW ist offensichtlich defekt, aber die ADSL-LED am Gerät blinkt orange statt rot für einen Defekt. Ich bin der Auffassung, dass es die Regelung gibt, dass ein Defekt durch eine rote LED zu signalisieren ist - die LED ist aber eineindeutig orange blinkend. Und das bedeutet für mich, dass das Gerät (bzw. das Modem) versucht zu synchronisieren. Schafft es das nicht, verbleibt es im orange blinkenden Modus und es ist anzunehmen, dass eine Störung auf Telekom-Seite vorliegt.
Dass ein Gerät oder Modem kaputt gehen kann, keine Frage. Aber bei einem LANCOM erwarte ich auch im Fehlerfall eine ordentliche Signalisierung der Zustände im Gerät. Rot blinkend hätte zur Folge gehabt, dass andere Entscheidungen getroffen worden wären, als sie gestern wurden. Der Zeitpunkt bis zur Fehlerbeseitigung wurde so unnötig hinausgezögert und die falschen Leute unnötig beschäftigt.

Hintergrund: Die Störung ist aus heiterem Himmel um 4:35 Uhr eingetreten. Unter Status/ADSL war der Line-State auf UNKNOWN. Unter Status/ADSL/Modem war Last-Error auf Firmware upload failed, Boot-Count 3395, Link 0, Modem-State Uploading Firmware.
Im Syslog stehen Sachen wie:
Hinweis xDSL: Booting modem: Quick memtest timeout
Hinweis xDSL: Booting modem: Timeout reading options
Hinweis xDSL: Booting modem: Firmare upload failed (da fehlt übrigens ein "w" im Wort "Firmware")
Hinweis xDSL: Booting modem: Ramdisk upload failed
Hinweis xDSL: Booting modem: Kernel upload failed
Hinweis xDSL: Booting modem: Heartbeat timeout
Hinweis xDSL: Booting modem: Await Heartbeat timeout (was ist soll das "Await" hier bedeuten?)
Aber alles auf dem Level "Notice" (Hinweis), kann auch irgendwo nicht sein, ein dramatischer Fehler und dann eine kleine Randnotiz im Syslog.

Zu allem Überfluss hat sich das Modem wieder aufgerappelt und funktionierte gestern Abend um 22:50 Uhr aus heiterem Himmel wieder - so plötzlich wie es ausfiel, war es jetzt wieder ok, auch nach einem Neustart. Zuvor wurde der 1781AW gegen 18:30 Uhr ausgetauscht und lief seitdem in resettetem Zustand im lokalen LAN zur Beobachtung weiter.

Vielen Dank und viele Grüße,
Jirka
13 Jahre LANCOM-Forum — 13 Jahre Kompetenz in Sachen LANCOM.

Maurice
Beiträge: 41
Registriert: 18 Sep 2017, 12:38

Re: ADSL-Modem defekt und DSL-LED blinkt weiter orange statt

Beitrag von Maurice » 19 Jan 2018, 17:22

Da muss ich als Mensch mit elektrotechnischem Background jetzt einfach was dazu sagen. :wink:

So ärgerlich das natürlich ist, aber eine Signalisierung "Modem defekt" setzt voraus, dass das Gerät das eindeutig diagnostizieren kann. Das ist nicht immer der Fall. Trivialbeispiel: Schlechter Kontakt / Lötstelle irgendwo im Modem. Natürlich versucht das Modem weiter zu synchronisieren. Wie soll es einen solchen Fehler auch zuverlässig von einer Leitungsstörung unterscheiden?

Benutzeravatar
Jirka
Beiträge: 4081
Registriert: 03 Jan 2005, 14:39
Wohnort: Ex-OPAL-Gebiet
Kontaktdaten:

Re: ADSL-Modem defekt und DSL-LED blinkt weiter orange statt

Beitrag von Jirka » 19 Jan 2018, 19:07

Hallo Maurice,
Maurice hat geschrieben:Da muss ich als Mensch mit elektrotechnischem Background jetzt einfach was dazu sagen.
ja, nur zu...
Maurice hat geschrieben:So ärgerlich das natürlich ist, aber eine Signalisierung "Modem defekt" setzt voraus, dass das Gerät das eindeutig diagnostizieren kann. Das ist nicht immer der Fall. Trivialbeispiel: Schlechter Kontakt / Lötstelle irgendwo im Modem. Natürlich versucht das Modem weiter zu synchronisieren. Wie soll es einen solchen Fehler auch zuverlässig von einer Leitungsstörung unterscheiden?
Das Gerät bekommt das aber in diesem Fall sehr wohl mit, denn es ist im Status und im Syslog zu sehen. Das ist für mich kein Argument.

Vielen Dank und viele Grüße,
Jirka
13 Jahre LANCOM-Forum — 13 Jahre Kompetenz in Sachen LANCOM.

Maurice
Beiträge: 41
Registriert: 18 Sep 2017, 12:38

Re: ADSL-Modem defekt und DSL-LED blinkt weiter orange statt

Beitrag von Maurice » 19 Jan 2018, 23:56

Jirka hat geschrieben: Das Gerät bekommt das aber in diesem Fall sehr wohl mit, denn es ist im Status und im Syslog zu sehen.
Stimmt, da hatte ich deine Syslog-Meldungen nicht genau genug gelesen. Das ist schon ziemlich eindeutig.

Benutzeravatar
MoinMoin
Moderator
Moderator
Beiträge: 1614
Registriert: 12 Nov 2004, 17:04

Re: ADSL-Modem defekt und DSL-LED blinkt weiter orange statt

Beitrag von MoinMoin » 22 Jan 2018, 14:59

Moin, moin!

Ja, Jirka, das kann man sicherlich besser Lösen. ich denk da mal drüber nach.

Ciao, Georg

Benutzeravatar
MoinMoin
Moderator
Moderator
Beiträge: 1614
Registriert: 12 Nov 2004, 17:04

Re: ADSL-Modem defekt und DSL-LED blinkt weiter orange statt

Beitrag von MoinMoin » 28 Feb 2018, 12:36

Moin, moin!

Ich hab mich des Themas mal angenommen. Die Änderungen kommen aber erst mit der 10.20.

Die Error-LED wird bei jedem Fehler aktiviert, der zu einem Neustart des Modems führt oder der einen Start des Modems verhindert. Das ist dann also auch der Fall, wenn beim Firmware-Upload mal wieder die Modem-Dateien verloren gegangen sind. Die genaue Ursache muß man dann im [A,V]DSL-Trace bzw. im [A,V]DSL-Modem-Status nachsehen. Die Error-LED wird wieder abgeschaltet, sobald das Modem erfolgreich gebootet hat (Modem-Zustand "Running") oder das Interface (erfolgreich) deaktiviert wird.

@Jirka: Entspricht das soweit deinen Vorstellungen?

Edit: Wenn das Modem ein Problem mit dem Frontend hat, wird das nicht als Fehler erkannt. Da fehlt dann tatsächlich die Möglichkeit zu erkenne, ob eine Verdindung zum DSLAM besteht oder nicht.

Ciao, Georg

Benutzeravatar
Jirka
Beiträge: 4081
Registriert: 03 Jan 2005, 14:39
Wohnort: Ex-OPAL-Gebiet
Kontaktdaten:

Re: ADSL-Modem defekt und DSL-LED blinkt weiter orange statt

Beitrag von Jirka » 02 Mär 2018, 00:02

Hallo Georg,

schön!
MoinMoin hat geschrieben:@Jirka: Entspricht das soweit deinen Vorstellungen?
Nun ja, es geht hier ja nicht um mich oder meine Vorstellungen, sondern um ein Verhalten der LED wie es zu erwarten sein sollte, eben wie man es optimalerweise macht, sodass der tatsächliche Zustand signalisiert wird. Und ich denke dem bist Du jetzt ein großes Stück weit näher gekommen, wenn nicht sogar so nah gekommen, wie man es eben machen kann - ich kann das jetzt nicht so ganz beurteilen, weil ich nicht so tief in der Materie stecke... Aber ich denke, das entspricht damit auch meinen Vorstellungen, ja.
MoinMoin hat geschrieben:Das ist dann also auch der Fall, wenn beim Firmware-Upload mal wieder die Modem-Dateien verloren gegangen sind.
Das ist ja zum Glück sehr selten der Fall, aber vor knapp 2 Monaten hatte ich den auch mal wieder... Bis ich festgestellt hatte, was dem Gerät fehlt, vergingen durch Ferndiagnose aber auch erst mal 20 Minuten... Insofern schön - das kann nun zukünftig schneller gehen.
MoinMoin hat geschrieben:Edit: Wenn das Modem ein Problem mit dem Frontend hat, wird das nicht als Fehler erkannt. Da fehlt dann tatsächlich die Möglichkeit zu erkenne, ob eine Verdindung zum DSLAM besteht oder nicht.
Das finde ich auch ok so und im Normalfall liegt ja dann das Problem auch vor dem LANCOM.

Wenn Du dann vielleicht auch noch was an den beiden anderen fett gedruckten Problemen im Eingangsposting gemacht hast, der kleine Rechtschreibfehler und der Level "Notice", obwohl Alarm, Warnung oder Fehler sicherlich passender wären (auf alle Fälle bei den "failed"-Meldungen, denke ich), dann wäre das sicherlich richtig super. :D

Vielen Dank und viele Grüße,
Jirka
13 Jahre LANCOM-Forum — 13 Jahre Kompetenz in Sachen LANCOM.

Antworten

Zurück zu „Feedback LCOS Release Update Betatest“