1783VAW Early-Media <->T-Sip-Trunk

LANCOM Systems VoIP Router: 1722 VoIP, 1723 VoIP, 1724 VoIP, 1823 VoIP, sowie LANCOM Routern mit VoIP und mit der LANCOM VoIP Option

Moderator: Lancom-Systems Moderatoren

Antworten
steveurkel
Beiträge: 43
Registriert: 03 Mai 2012, 18:25

1783VAW Early-Media <->T-Sip-Trunk

Beitrag von steveurkel » 20 Mai 2018, 22:25

.... Ich update mal die Frage: Ist Early Media überhaupt implementiert?


Hallo,

ursprünglich bin ich auf der Suche nach dem Fehler der "verschluckten ersten Sekunden". Ursache ist das der der Sprachweg erst ausgehandelt wird sobald der Hörer abgehoben wird. Ich habe mir eine nicht genutzte Rufnummer geschnappt und versuche damit Audio zu senden bevor abgehoben wird. (Handy ruft Lancom/Asterisk an) Scheinbar wird aber das Session Progress vom Lancom ignoriert.

Asterisk-Log zeigt das er ein 183 Session Progress an den Lancom sendet (IP 192.168.10.254)

Code: Alles auswählen

<--- Transmitting (no NAT) to 192.168.10.254:5060 --->
SIP/2.0 183 Session Progress
Via: SIP/2.0/UDP 192.168.10.254:5060;branch=z9hG4bK-dfda20ec-e12e2a70;received=192.168.10.254
From: <sip:001763012345678@sip-trunk.telekom.de;user=phone>;tag=1551748395-1002571444
To: <sip:6900051@intern;user=phone>;tag=as7fb685e2
Call-ID: 3563796100@00a0572e9563
CSeq: 1 INVITE
Server: Asterisk
....
...und spielt jetzt ein Audiofile ab das auf dem Handy nicht zu hören ist. Stattdessen bekommt man ein Klingelzeichen.
(ich habe selbstverständlich ausprobiert das das Audiofile funktioniert, dazu habe ich Asterisk vorher angewiesen den Anruf erst anzunehmen.)

Im Lancom-Trace stellt sich das so dar:

-Es kommt der Invite vom Provider rein

-Lancom antwortet mit Trying:

Code: Alles auswählen

Sending datagram with length 511 from 93.193.xx.yy:11394 to 217.0.26.197:5060 using TCP
SIP/2.0 100 Trying\r\n
-Lancom sendet seinerseits einen Invite an den SIP-User der Asterisk

-Asterisk antwortet seinerseits mit Trying:

Code: Alles auswählen

Receiving datagram with length 487 from 192.168.10.198:5060 to 192.168.10.254:5060 using UDP
SIP/2.0 100 Trying\r\n
-Jetzt sendet Asterisk ein 183 Session Progress:

Code: Alles auswählen

[SIP-Packet] 2018/05/20 21:29:13,745  Devicetime: 2018/05/20 21:29:16,028 [PACKET] : 
Receiving datagram with length 820 from 192.168.10.198:5060 to 192.168.10.254:5060 using UDP
SIP/2.0 183 Session Progress\r\n             
Um jetzt Early-Media erfolgreich rüberzubringen müsste nach meiner Meinung der Lancom jetzt ebenfalls ein 183 senden, stattdessen signalisiert er direkt ein Ringing:

Code: Alles auswählen

[SIP-Packet] 2018/05/20 21:29:13,745  Devicetime: 2018/05/20 21:29:16,030 [PACKET] : 
Sending datagram with length 512 from 93.193.xx.yy:11394 to 217.0.26.197:5060 using TCP                                     
SIP/2.0 180 Ringing\r\n
Via: SIP/2.0/TCP 217.0.26.197:5060;branch=z9hG4bKeb4fd9c1f1887595a033d94177ebcb05.56bd3023\r\n
-TK-Anlage ist ein Asterisk
-Router ist ein 1783VAW, LCOS 9.24.0334SU9
-Telefonie-Provider ist Telekom, Deutschlandlan-Sip-Trunk

Ist das ein Bug? Early-Media war schon in den alten Geräten implementiert...

PS: ich nutze den gleichen Router daheim auch. Asterisk/Raspberry. Als ich dort probehalber mal das aktuelle LCOS 10.12.0292 aufgespielt hatte passierte folgendes:

-Handy ruft an, internes Telefon klingelt.
-Handy legt auf
-internes Telefon klingelt weiter!

steveurkel
Beiträge: 43
Registriert: 03 Mai 2012, 18:25

Re: 1783VAW Early-Media <->T-Sip-Trunk

Beitrag von steveurkel » 24 Mai 2018, 06:37

Ich hole die Sache nochmal und update die Frage:

Ist Early Media überhaupt implementiert?

awi
Beiträge: 21
Registriert: 19 Jun 2013, 15:22

Re: 1783VAW Early-Media <->T-Sip-Trunk

Beitrag von awi » 24 Mai 2018, 15:46

Hallo,

Early-Media sollte eigentlich funktionieren, sowohl in der 9.24 als auch in einer aktuellen 10.12.
Schon seltsam, dass da von der Asterisk ein Session Progress kommt und der LANCOM dann ein Ringing raus schickt.

Kannst du mir Traces dazu schicken? (Sip-Packet, Callmanager, Sip-Connection und Media)

Gruß
awi

steveurkel
Beiträge: 43
Registriert: 03 Mai 2012, 18:25

Re: 1783VAW Early-Media <->T-Sip-Trunk

Beitrag von steveurkel » 27 Mai 2018, 21:52

..wie soll ich dir den Trace zukommen lassen? Mail/PN? Es sind knapp 1000 Zeilen.

Andyet
Beiträge: 14
Registriert: 09 Feb 2017, 20:48

Re: 1783VAW Early-Media <->T-Sip-Trunk

Beitrag von Andyet » 03 Jun 2018, 19:05

Hallo zusammen,

Das mit den verschluckten ersten Sekunden kenne ich auch. Allerdings mit einer Fritzbox, die sich am VCM anmeldet und nur mit G722.

Traces dazu habe ich mir noch nicht angeschaut. Ich wüsste aber auch nicht, wo ich im Lancom oder Fritzbox etwas einstellen könnte, damit man direkt etwas hört.
Evtl. Ist das ja auch ein Early Media Problem und nicht nur bei mir.

Viele Grüsse Andy


Gesendet von iPad mit Tapatalk

steveurkel
Beiträge: 43
Registriert: 03 Mai 2012, 18:25

Re: 1783VAW Early-Media <->T-Sip-Trunk

Beitrag von steveurkel » 05 Jun 2018, 22:09

Ja, es ist ein Problem beim Early-Media. Ich kann inzwischen so viel dazu sagen: An meiner Asterisk-Config lag es nicht.

Antworten

Zurück zu „LANCOM Systems VoIP Router“